请选择 进入手机版 | 继续访问电脑版

关于ARDUINO的版本使用建议,开发UNO/MEGA2560的板子,请使用ARDUNO IDE 1.0.6版本 

2018-04-13 21:41 发布

7391 0 0

1.经过大概5年左右对ARDUINO的使用,发现支持最多库,对ARDUINO UNO / ARDUINO MEGA2560这些8bit板子支持最稳定的是1.0.6版本。比如一些常见的液晶库,定时器库,彩屏库等等都在这个版本完美运行,也是github等很多网站开源库大部分都是支持这个版本,而其他版本会有各种意想不到的bug。
2.而1.5x 1.6x  1.7x  1.8x主要更新的一些新的型号的ARDUINO板子,比如一些32bit内核的板子的支持,当为了做顾全更多ARDUINO板子,系统的兼容性就更差,很多库在这些版本运行不了,很多程序也会运行出错。
我们看下官方对这些版本的介绍
https://www.arduino.cc/en/Main/OldSoftwareReleases#previous

ARDUINO 1.0.6
Classic Arduino IDE, to be used with any Arduino board, but Arduino Yún and Arduino DUE. Refer to the Getting Started page for Installation instructions. See the release notes.

ARDUINO 1.8.4
Arduino IDE that can be used with any Arduino board, including the Arduino Yún and Arduino DUE. Refer to the Getting Started page for Installation instructions. See the release notes.

我们看到1.0.6版本是最经典的版本。但是不支持yun due等新ARDUINO板子开发。
3.如果做您使用的是ARDUINO UNO板子,或者ARDUINO MEGA2560板子,建议使用最稳定最经典的的1.0.6版本,官方对1.0.6版本的说明说的最经典版本【Classic】
下载地址:
链接:https://pan.baidu.com/s/1tC4FpJawq4g20Rr8gqn8VQ
提取码:n0ta

或者官方下载地址:
https://www.arduino.cc/en/Main/OldSoftwareReleases#previous
找到合适的安装包4.如果真是用到一些高端板子,比如yun due等,可以下载其他的版本zip免安装版本直接解压使用,这样同一个电脑可以存在多个版本使用。




B Color Smilies
快速回复 返回顶部 返回列表